Firefox 3.6 será más estable

Firefox 3.6 será más estable
18 de noviembre, 2009

Una de las novedades que llegarán con Firefox 3.6 será la inclusión de un mecanismo llamado “Component Directory Lockdown”, que estará destinado a impedir el uso de complementos no del todo compatibles. En pasadas ediciones los desarrolladores de plugins y complementos han logrado “colar” sus extensiones aunque no fueran totalmente compatibles con las últimas revisiones de Firefox, lo que provocaba problemas de estabilidad que ahora no se producirán gracias a esta nueva tecnología. 

 

Estamos haciendo esto por la estabilidad y para el control de usuarios“, explicaba Jonathan Nightingale, responsable del equipo de desarrollo del frontend de Firefox. “Estamos eliminando componentes de esta forma, que nunca fue un método oficial de hacer las cosas [desarrollar complementos], lo que significa que no disponían de cosas que entre otras cosas especificaban la compatibilidad con la aplicación“.

 

 

Cuando una nueva versión de Firefox aparece y hay componentes que no son compatibles con ella, los resultados pueden ser realmente molestos para nuestros usuarios“, añadía Nightingale, que explicaba en un correo electrónico que el nuevo componente de Firefox 3.6 llamado Component Directory Lockdown se encargará precisamente de bloquear esas extensiones incompatibles en mayor o menor medida.

 

Aunque muchas de las extensiones y complementos de Firefox están disponibles desde el sitio oficial de complementos de Firefox, hay “extensiones pirata” que solo es posible encontrar en las páginas web de sus desarrolladores, y el peligro está precisamente en complementos que no han sido verificados para su utilización con ciertas versiones del navegador, y que causan más perjuicio que beneficio. Así pues, es de esperar que Firefox 3.6 sea un navegador más estable frente a esas extensiones no verificadas.

 

  • Share This